Jump to content

Our Official NAGF Flags

are now available in the NAGF Online Store in TWO Sizes! Don't miss your chance of being one of the first to fly the new high visibility NAGF Flag!!!

 

Click Here To Go To the NAGF Online Store!!!

 

Snag_1ffcf50.png

NAGF Admin NAGF Admin
NAGF News Ticker
     
  • Happy 4th of July Everyone!!!
  • New Members are always welome!!!
  • NAGF
Sign in to follow this  
Kalsow

1999 1500 SE with electrical issue

5 posts in this topic Last Reply

Recommended Posts

Kalsow

My 1999 1500SE Trike has gone through 3 batteries, which all end up with "bad cells," and neither of two dealers havebeen able to diagnose the problem. One replaced the alternator, still no fix. Both say all their electrical diagnostic tests turn out OK.. Any thoughts?

 

Thanks,

 

Larry

 

 

 

Share this post


Link to post
Share on other sites
Bamaeagle

Welcome to the forum.....:wave:

 

You would get better info if you posted your questions in the 1500 tech section.

 

My first thought would be to change battery brands......:baffled:

Share this post


Link to post
Share on other sites
papa g

:wave::wave::wave:Welcome to the forum from Canadas west coast Vancouver Island.

 

Sounds like a dead short check battery and cables not touching frame.

Share this post


Link to post
Share on other sites
Kalsow

Thanks for the tips.

Share this post


Link to post
Share on other sites
Joep

Welcome from North TEXAS DFW area.....

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use,